Главная / apple / Пользователи старых версий iOS и macOS оказались под угрозой

Пользователи старых версий iOS и macOS оказались под угрозой

Очередная серьезная уязвимость была найдена специалистами китайской компании Tencent Security Xuanwu Lab. Эксперты обнаружили ошибку в Safari. По их словам, у фирменного браузера есть слабое место — используя особую последовательность действий, хакеры способны замаскировать адрес вредоносного веб-сайта таким образом, чтобы он отображался как подлинный. Ошибка оказалась глобальной и затрагивает все версии iOS вплоть до 11.4.1, и macOS до 10.13.6.

ЧИТАЙТЕ ТАКЖЕ: Опачки! Владельцы нового iPad Pro массово жалуются на хрупкий корпус

По утверждениям специалистов, проблема имеет место быть как на мобильной, так и настольной версии Safari. Все дело в том, что в фирменном браузере Apple некоторые кодированные символы отображаются как обычные латинские буквы. Например, злоумышленники могут заменить латинскую букву d на символ dum из Unicode в имени домена, а затем отправить ссылку на вредоносный сайт, выдавая его за действительный. Из-за того, что внешне ссылка ничем не отличается от подлинной, пользователь может не заметить разницы и таким образом передать свои конфиденциальные данные хакерам.

Для наглядной демонстрации, специалисты по безопасности заменили домен iCloud.com на поддельный. Что примечательно, проблеме подвержен оказался только браузер Safari, тогда как в адресной строке Google Chrоme, Microsoft Edge и Firefox был отчетливо виден вредоносный домен.

ЧИТАЙТЕ ТАКЖЕ: Пользователи пожаловались еще на две проблемы в работе iOS 12.0.1

По словам хакеров, вся необходимая информация была отправлена в Apple еще в апреле. Тем не менее проблема была исправлена лишь с выходом macOS Mojave и iOS 12. Так как уязвимость была признана критической, всем пользователям iPhone и iPad с iOS 11.4.1 и ниже, а также владельцам компьютеров Mac с установленной macOS High Sierra 10.13.6 или более старых версий, рекомендовано как можно скорее обновиться до новейших версий ПО.